contains native libraries that will not run on the device

又在uc的sdk上遇到了这个问题

项目已经没有报错,但是连接真机调试的时候提示这个错误

屏幕快照 2015-11-22 11.47.40.png

The library 'UCGameSDK-3.5.3.1.jar' contains native libraries that will not run on the device.
[2015-11-22 11:47:27 - Caribbean_YiJieUC] The following libraries were found:
[2015-11-22 11:47:27 - Caribbean_YiJieUC]  - assets/ucgamesdk/so/libsdk_bspatch.so

而在导出的时候又会报错

Native libraries detected in 'android_1848884733045993189.jar'. See console for more information.

这里还是那个解决办法

屏幕快照 2015-11-22 11.46.48.png

在设置的Build里面,把第二个关闭,第一个也可以关闭

  • windows的设置在:windows->Preferences...

  • mac的设置在file->Preferences

参考文章:

http://stackoverflow.com/questions/4882167/creating-a-product-sdk-how-do-i-add-a-native-lib-so-and-a-jar-with-the-sdk-i

Last modification:January 1st, 1970 at 08:00 am
如果看了这个文章可以让你少加会班,可以请我喝杯可乐
已打赏名单
微信公众号

Leave a Comment