java.lang.NoClassDefFoundError: android.support.v4.content.LocalBroadcastManager

报错信息:


03-24 18:22:46.363: W/System.err(12420): java.lang.NoClassDefFoundError: android.support.v4.content.LocalBroadcastManager
03-24 18:22:46.363: W/System.err(12420): 	at com.facebook.UiLifecycleHelper.<init>(UiLifecycleHelper.java:72)
03-24 18:22:46.364: W/System.err(12420): 	at com.ff.sdk.LoginActivity.onCreate(LoginActivity.java:85)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.Activity.performCreate(Activity.java:5135)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1146)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2329)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2417)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.ActivityThread.access$600(ActivityThread.java:169)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1377)
03-24 18:22:46.364: W/System.err(12420): 	at android.os.Handler.dispatchMessage(Handler.java:107)
03-24 18:22:46.364: W/System.err(12420): 	at android.os.Looper.loop(Looper.java:194)
03-24 18:22:46.364: W/System.err(12420): 	at android.app.ActivityThread.main(ActivityThread.java:5449)
03-24 18:22:46.365: W/System.err(12420): 	at java.lang.reflect.Method.invokeNative(Native Method)
03-24 18:22:46.365: W/System.err(12420): 	at java.lang.reflect.Method.invoke(Method.java:525)
03-24 18:22:46.365: W/System.err(12420): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:833)
03-24 18:22:46.365: W/System.err(12420): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:600)
03-24 18:22:46.365: W/System.err(12420): 	at dalvik.system.NativeStart.main(Native Method)


这个是因为没有引入android-support-v4.jar这个文件

这个文件就是为了兼容性使用的,如果没有引入的话程序里面不会有错,但是当程序安装到手机使用的时候,如果不兼容会出现闪退的情况

所以只要把这个文件直接拖到eclipse项目的 libs 文件下即可

如果还不正确,可能是引用的地方不正确,可以参考这个文章

http://stackoverflow.com/questions/8579915/android-support-v4-jar-isnt-importing-correctly-in-eclipse


如果没有这个文件或者找不到,我这里分享了一个,可以下载下来然后直接引用

还有一种情况是 facebook 的,有时候会出现错误,因为 facebook 自己就带这个,所以如果接 facebook 出现这个错误,可以使用 facebook 的那个android-support-v4.jar替换这个就可以了

链接:http://pan.baidu.com/s/1hhojc密码: sd17

Last modification:January 1st, 1970 at 08:00 am
如果看了这个文章可以让你少加会班,可以请我喝杯可乐
已打赏名单
微信公众号

Leave a Comment